Simulasi QoS (Quality of Service) pada Cisco Router

Untuk kesempatan kali ini, saya akan mencoba untuk membagikan tutorial networking.
Tutotial kali ini yaitu mencoba untuk mengkonfigurasi QoS (Quality of Service) pada Router Vendor Cisco.

Hmmm,,, lagi-lagi saya menggunakan simulasi GNS3.

Sebelum benar-benar mengkonfigurasinya, harap teman-teman mengerti apa itu QoS.
Menurut wikipedia:

Quality of Service (disingkat menjadi QoS) merupakan mekanisme jaringan yang memungkinkan aplikasi-aplikasi atau layanan dapat beroperasi sesuai dengan yang diharapkan. Kinerja jaringan komputer dapat bervariasi akibat beberapa masalah, seperti halnya masalah bandwidth, latency dan jitter, yang dapat membuat efek yang cukup besar bagi banyak aplikasi. Sebagai contoh, komunikasi suara (seperti VoIP atau IP Telephony) serta video streaming dapat membuat pengguna frustrasi ketika paket data aplikasi tersebut dialirkan di atas jaringan dengan bandwidth yang tidak cukup, dengan latency yang tidak dapat diprediksi, atau jitter yang berlebih. Fitur Quality of Service (QoS) ini dapat menjadikan bandwidth, latency, dan jitter dapat diprediksi dan dicocokkan dengan kebutuhan aplikasi yang digunakan di dalam jaringan tersebut yang ada.”

Untuk konfigurasi kali ini, topology yang akan saya coba seperti dibawah ini:

Sebelum konfigurasi QoS.

Mencoba melakukan perintah “ping”.

Setelah melakukan pengiriman paket.

Verifikasi pada Router_2

Final Configuration.

Router_1

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ROUTER_1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
class-map match-all DIRECTOR-CLASS
 description ***QoS for BOS***
 match access-group 1
!
!
policy-map DIRECTOR-POLICY
 description ***Policy QoS for Director***
 class DIRECTOR-CLASS
  set precedence 5
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 description ***Link to Director Room***
 ip address 10.10.12.1 255.255.255.252
 speed 100
 full-duplex
 service-policy input DIRECTOR-POLICY
!
interface FastEthernet0/1
 description ***Link to Manager Room***
 ip address 10.10.13.1 255.255.255.252
 speed 100
 full-duplex
!
interface FastEthernet1/0
 ip address 140.1.1.1 255.255.255.252
 speed 100
 full-duplex
!
router eigrp 1
 network 1.0.0.0
 network 10.0.0.0
 network 140.1.0.0
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
access-list 1 permit 10.10.12.0 0.0.0.3
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

Router_2

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ROUTER_2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
class-map match-all CLASS-DIRECTOR
 match  precedence 5
!
!
policy-map DIRECTOR-PRIORITY
 class CLASS-DIRECTOR
  priority percent 20
!
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 140.1.1.2 255.255.255.252
 speed 100
 full-duplex
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 service-policy output DIRECTOR-PRIORITY
!
router eigrp 1
 network 2.2.2.2 0.0.0.0
 network 140.1.0.0
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

Director_PC

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname DIRECTOR_PC
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.10.12.2 255.255.255.252
 speed 100
 full-duplex
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 1
 network 10.10.12.0 0.0.0.3
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

Manager_PC

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname MANAGER_PC
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.10.13.2 255.255.255.252
 speed 100
 full-duplex
!
router eigrp 1
 network 10.10.13.0 0.0.0.3
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end
About these ads
  1. Tinggalkan komentar

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Logout / Ubah )

Twitter picture

You are commenting using your Twitter account. Logout / Ubah )

Facebook photo

You are commenting using your Facebook account. Logout / Ubah )

Google+ photo

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

Ikuti

Get every new post delivered to your Inbox.

%d bloggers like this: